Composer update fails with composer.json PHP version ^7.1.3

Hi geeks, yesterday I tried to run a command in my laravel project ver 5.8 then it’s showing two issues in my git bash. my PHP version in the composer.json file is “^7.1.3”.

Problem 1
    - Root composer.json requires php ^7.1.3 but your php version (8.0.0) does not satisfy that requirement.
  Problem 2
    - laravel/framework[v5.8.0, ..., 5.8.x-dev] require php ^7.1.3 -> your php version (8.0.0) does not satisfy that requirement.
    - Root composer.json requires laravel/framework 5.8.* -> satisfiable by laravel/framework[v5.8.0, ..., 5.8.x-dev].

Composer update command issue

whenever you find these type of issue then try below command to solve the issue: if sometimes your issue will not resolve by below command then please comment us for more solution on this type of issue.

composer install --ignore-platform-reqs

For more understanding on these issues please read the below ref:

I hope your issue has been resolved, If not feel free to comment .

Shaiv Roy

Hy Myself shaiv roy, I am a passionate blogger and love to share ideas among people, I am having good experience with laravel, vue js, react, flutter and doing website and app development work from last 7 years.

Related Articles

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button